Saturday, January 14, 2017

CCIE SPv4 - MPLS L3 VPN - RIPv2

Software versions:
IOS XE 15.5
IOS XR 5.3

The topology for this demo:
In this post we'll take a look at RIPv2 as the PE-CE routing protocol. There isn't a whole lot to cover here, both IPv4 and IPv6 are supported in IOS, only IPv4 is supported on XR. 

R1
ipv6 rip vrf-mode enable
!
interface GigabitEthernet1.1120
 encapsulation dot1Q 1120
 vrf forwarding RIPv2
 ip address 131.0.0.1 255.255.255.0
 ipv6 address 2131:CC1E::1/64
 ipv6 rip CCIE enable
!
router rip
 !
 address-family ipv4 vrf RIPv2
  redistribute bgp 50693 metric transparent
  network 131.0.0.0
  no auto-summary
  version 2
 exit-address-family
  redistribute rip metric 5
  redistribute rip CCIE metric 5
ipv6 router rip CCIE
 !
 address-family ipv6 vrf RIPv2
  redistribute bgp 50693 metric 5
 exit-address-family
!
router bgp 50693
address-family ipv4 vrf RIPv2
  redistribute rip metric 5
 exit-address-family
 !
 address-family ipv6 vrf RIPv2
  redistribute rip CCIE metric 5
 exit-address-family



R13
ipv6 rip vrf-mode enable
!
interface GigabitEthernet1.1120
 encapsulation dot1Q 1120
 vrf forwarding RIPv2
 ip address 131.0.0.13 255.255.255.0
 ipv6 address 2131:CC1E::13/64
 ipv6 rip CCIE enable
!
router rip
 !
 address-family ipv4 vrf RIPv2
  network 131.0.0.0
  network 172.16.0.0
  no auto-summary
  version 2
 exit-address-family
ipv6 router rip CCIE
 !
 address-family ipv6 vrf RIPv2
 exit-address-family


XR3
router rip
 vrf RIPv2
  interface GigabitEthernet0/0/0/0.1120
  !
  redistribute bgp 50693


R14
ipv6 rip vrf-mode enable
!
interface GigabitEthernet1.1120
 encapsulation dot1Q 1312
 vrf forwarding RIPv2
 ip address 113.0.0.14 255.255.255.0
 ipv6 address 2113:CC1E::14/64
 ipv6 rip CCIE enable
!
router rip
 !
 address-family ipv4 vrf RIPv2
  network 113.0.0.0
  no auto-summary
  version 2
 exit-address-family
ipv6 router rip CCIE
 !
 address-family ipv6 vrf RIPv2
 exit-address-family


To verify the configuration. 

R1#sh bgp vpnv4 unicast vrf RIPv2 113.0.0.0/24
BGP routing table entry for 120:50693:113.0.0.0/24, version 228
Paths: (2 available, best #2, table RIPv2)
  Not advertised to any peer
  Refresh Epoch 1
  Local
    192.168.1.13 (metric 3) (via default) from 192.168.1.14 (192.168.1.14)
      Origin incomplete, metric 5, localpref 100, valid, internal
      Extended Community: RT:120:50693
      Originator: 192.168.1.13, Cluster list: 192.168.1.14
      mpls labels in/out nolabel/24014
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 2
  Local
    192.168.1.13 (metric 3) (via default) from 192.168.1.2 (192.168.1.2)
      Origin incomplete, metric 5, localpref 100, valid, internal, best
      Extended Community: RT:120:50693
      Originator: 192.168.1.13, Cluster list: 192.168.1.2
      mpls labels in/out nolabel/24014
      rx pathid: 0, tx pathid: 0x0

A couple of things to note, the metric is 5, which is what was configured on the PE devices. 

R13#sh ip route vrf RIPv2 113.0.0.0

Routing Table: RIPv2
Routing entry for 113.0.0.0/24, 1 known subnets
  Redistributing via rip
R        113.0.0.0 [120/6] via 131.0.0.1, 00:00:20, GigabitEthernet1.1120

You can see that R13 has learned the 113.0.0.0/24 with a metric of 6, which is the metric advertises by the PE on the remote end and what R1 advertised to reach R13. 

R13#traceroute vrf RIPv2 113.0.0.14
Type escape sequence to abort.
Tracing the route to 113.0.0.14
VRF info: (vrf in name/id, vrf out name/id)
  1 131.0.0.1 5 msec 2 msec 0 msec
  2 10.1.12.12 [MPLS: Labels 24009/24014 Exp 0] 12 msec 13 msec 9 msec
  3 10.12.13.13 6 msec 16 msec 10 msec
  4 113.0.0.14 13 msec *  8 msec

As you can see, we have reachability. 

Thanks for stopping by!
Rob Riker, CCIE #50693

No comments:

Post a Comment