There are a few new terms and breakdowns we must cover before covering the configuration and verification.
The first is going to be the PMSI or Provider Multicast Service Interface, which enables the separation between the service and the transport mechanisms. This is an overlay on the provider core that takes packets from one PE and sends the packets to the other PE routers in the MVPN. A PMSI can only belong to one MVPN at any time but multiple PMSIs can exist in a single MVPN.
The second are the different types of PMSIs, The MI-PMSI or Multidirectional Inclusive PMSI is any PE to all PE communication. Essentially traffic sent by any ingress PE will be received by all other PE routers in a given MVPN instance. Think of this as the Default MDT.
The UI-PMSI is the Unidirectional Inclusive PMSI is for traffic from a particular PE to all PEs.
The S-PMSI is the Selective PMSI is for traffic from a particular PE to another PE or subset of PEs. This is typically the PMSI that is used for SSM traffic seen later in the post during testing.
Rosen models to PMSI comparison; The default MDT is comparable to the MI-PMSI and The data MDT is comparable to the I-PMSI
There are several Route Types introduced as we are adding a new BGP AFI to the design, the MVPN AFI.
BGP MVPN offers three major capabilities, Auto Discovery, P Tunnel Signaling and C-Multicast route signaling. Auto Discovery enable the ability for the PE routers to find other PE routers participating in a given MVPN instance. P Tunnel signaling is the PE to PE signaling for the method chosen for transporting C-Multicast traffic. This could be, P2MP RSVP-TE, P2MP mLDP,MP2MP mLDP, mGRE or Ingress replication. Finally, C-Multicast route signaling is for exchanging customer multicast traffic control plane state like customer Joins, prunes and register messages. Important to note, that C is Customer and P is Provider. For instance C(*, G) is a Customer (*, G) where P(*, G) is Provider (*, G).
Route Types
Type 1 Intra AS I-PMSI AD
Originated by all the PE routers and responsible for learning intra AS MVPN membership
Type 2 Inter AS I-PMSI AD
Originated by ASBR routers and responsible for learning inter AS MVPN membership
Type 3 S-PMSI AD
Originated by the source PE and responsible for signaling the Data MDT
Type 4 Leaf AD
Originated by the receiver PE routers in response to a Type 3 announcement
It is used for indicating interest for a give C(S,G) multicast stream
Type 5 Source Active AD
Advertised by a Source PE when it learns about an active Multicast source and helps in the SPT switchover
This is announced to all Receiver PE routers that belong to a given MVPN
This route only applies to PIM SM mode
Type 6 Shared Tree Join
Advertised by a Receiver PE when a PIM Shared Tree Join C(*,G) is received from the CE device
Type 7 Source Tree join
Advertised by a Receiver PE when a C(S,G) Join is received or when it receives a Type 5 route announcement from an ingress PE
Route Types 1, 2 and 3 include PMSI tunnel attributes
Flags, 1 octet
Tunnel type, 1 octet
MPLS label, 3 octets
Tunnel identifier, can vary
Flags
Reserved - L
L = Leaf Information required
When set to 1 the PE receiving the route must originate a new Leaf AD Type 4 Route
Tunnel Types
1
|
RSVP-TE P2MP LSP
|
2
|
mLDP P2MP LSP
|
3
|
PIM-SSM Tree (P-S, P-G) with GRE Transport
|
4
|
PIM-SM Tree (*,P-G) with GRE Transport
|
5
|
PIM-BiDir Tree with GRE Transport
|
6
|
Ingres Replication, Set of Point to Point LSPs signaled via LDP or RSVP
|
7
|
mLDP MP2MP LSP
|
We'll begin by configuring the PE routers and then the RR.
R1, R3 and R7
vrf definition MVPN
!
address-family ipv4
mdt auto-discovery pim
!
router bgp 1.50693
!
address-family ipv4 mvpn
neighbor 192.0.2.22 activate
neighbor 192.0.2.22 send-community extended
exit-address-family
XR1
route-policy RPL_PROFILE_3
set core-tree pim-default
end-policy
!
multicast-routing
!
vrf CORE
address-family ipv4
bgp auto-discovery pim
!
router pim
!
vrf CORE
address-family ipv4
rpf topology route-policy RPL_PROFILE_3
!
router bgp 1.50693
address-family ipv4 mvpn
!
neighbor 192.0.2.22
address-family ipv4 mvpn
!
!
vrf CORE
address-family ipv4 mvpn
!
XR2
router bgp 1.50693
address-family ipv4 mvpn
!
neighbor 192.0.2.1
address-family ipv4 mvpn
route-reflector-client
!
!
neighbor 192.0.2.3
address-family ipv4 mvpn
route-reflector-client
!
!
neighbor 192.0.2.7
address-family ipv4 mvpn
route-reflector-client
!
!
neighbor 192.0.2.21
address-family ipv4 mvpn
route-reflector-client
RP/0/0/CPU0:XR2#show bgp ipv4 mvpn summary
Tue Dec 18 01:06:27.293 UTC
BGP router identifier 192.0.2.22, local AS number 1.50693
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 27
BGP NSR Initial initsync version 4 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs
BGP is operating in STANDALONE mode.
Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 27 27 27 27 27 0
Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
192.0.2.1 0 1.50693 14083 12572 27 0 0 6d07h 2
192.0.2.3 0 1.50693 13884 12571 27 0 0 6d07h 1
192.0.2.7 0 1.50693 13882 12573 27 0 0 6d07h 1
192.0.2.21 0 1.50693 12634 12704 27 0 0 6d06h 6
Looking at the output above, we see that the RR has formed MVPN Peering with all of the PE routers.
R1#sh bgp ipv4 mvpn all
BGP table version is 414, local router ID is 192.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf MVPN)
*> [1][100:100][192.0.2.1]/12
0.0.0.0 32768 ?
*>i [1][100:100][192.0.2.3]/12
192.0.2.3 0 100 0 ?
*>i [1][100:100][192.0.2.7]/12
192.0.2.7 0 100 0 ?
*>i [1][100:100][192.0.2.21]/12
192.0.2.21 100 0 i
*> [3][100:100][192.0.2.15][232.0.0.1][192.0.2.1]/22
0.0.0.0 32768 ?
*>i [3][100:100][192.0.2.16][224.1.1.2][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][225.1.1.1][192.0.2.21]/22
Network Next Hop Metric LocPrf Weight Path
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][226.1.1.1][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][227.1.2.3][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][232.0.0.1][192.0.2.21]/22
192.0.2.21 100 0 i
The first thing we need to breakdown is the BGP MVPN outputs, they are a bit different from what we've seen in the past.
The [1] indicates a intra AS PE, PE routers inside of the local AS.
The [100:00] indicates the Route Distinguisher.
The [192.0.2.15] and [192.0.2.16] are the sources IP addresses.
The [232.0.0.1], [224.1.1.2] and other multicast addresses are the multicast groups.
The [192.0.2.1] and [192.0.2.21] are the Route type 3 originator ID.
R1#sh bgp ipv4 mvpn all route-type 3 192.0.2.16 232.0.0.1 192.0.2.21
BGP routing table entry for [3][100:100][192.0.2.16][232.0.0.1][192.0.2.21]/22, version 25
Paths: (1 available, best #1, table MVPNv4-BGP-Table, not advertised to EBGP peer)
Not advertised to any peer
Refresh Epoch 1
Local
192.0.2.21 (metric 3) from 192.0.2.22 (192.0.2.22)
Origin IGP, localpref 100, valid, internal, best
Community: no-export
Extended Community: RT:100:100
Originator: 192.0.2.21, Cluster list: 192.0.2.22
PMSI Attribute: Flags: 0x0, Tunnel type: 3, length 8, label: exp-null, tunnel parameters: C000 0215 E815 1504
rx pathid: 0, tx pathid: 0x0
R1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.0.2.21, 232.21.21.4), 6d06h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.14, RPF nbr 100.64.14.4
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d06h/00:01:31
(192.0.2.21, 232.0.0.1), 6d06h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.14, RPF nbr 100.64.14.4
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d06h/00:01:24
(192.0.2.1, 232.0.0.1), 6d12h/00:02:53, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1.14, Forward/Sparse, 6d07h/00:02:34
GigabitEthernet1.12, Forward/Sparse, 6d07h/00:02:53
(192.0.2.7, 232.0.0.1), 6d12h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.14, RPF nbr 100.64.14.4
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d07h/00:01:29
(192.0.2.3, 232.0.0.1), 6d12h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.12, RPF nbr 100.64.12.2
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d07h/00:01:29
(192.0.2.1, 232.1.1.0), 6d07h/00:03:09, flags: sTz
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1.14, Forward/Sparse, 6d07h/00:03:09
In the above output, we see the P(S, G) connections between the PE routers. There are also 2 P(S, G) entries, 1 from R1, the (192.0.2.1, 232.1.1.0) and XR1, the (192.0.2.21, 232.21.21.4).
R1#sh ip mroute vrf MVPN
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.0.2.15, 232.0.0.1), 1w0d/00:03:03, flags: sTy
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 6d07h/00:03:03
(192.0.2.16, 232.0.0.1), 1w0d/00:02:31, flags: sTY
Incoming interface: Tunnel0, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.4]/never
Outgoing interface list:
GigabitEthernet1.201, Forward/Sparse, 6d06h/00:02:31
(*, 226.1.1.1), 1w0d/00:02:48, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 6d07h/00:02:48
(192.0.2.16, 226.1.1.1), 6d06h/stopped, flags: PT
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
(*, 225.1.1.1), 6d12h/00:03:22, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 6d07h/00:03:22
(192.0.2.16, 225.1.1.1), 6d05h/stopped, flags: P
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
(*, 227.1.2.3), 6d06h/00:02:33, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 6d06h/00:02:33
(192.0.2.16, 227.1.2.3), 03:28:13/stopped, flags: P
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
(*, 224.1.1.2), 1w1d/00:02:39, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 6d07h/00:02:39
(192.0.2.16, 224.1.1.2), 03:28:24/stopped, flags: P
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
R1 is the PE connected to the C-RP, the (*, G) entries, (*, 224.1.1.2) and others will show an RP of 192.0.2.15. They also have an OIL of Tunnel 0. Except for the (192.0.2.16, 232.0.0.1) since R16 is one of the sources, the IIF is the tunnel and the OIL is the connected PE-CE link. The (S, G) entries will show an IIF as the tunnel and OIL as null.
R7#sh bgp ipv4 mvpn all
BGP table version is 231, local router ID is 192.0.2.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf MVPN)
*>i [1][100:100][192.0.2.1]/12
192.0.2.1 0 100 0 ?
*>i [1][100:100][192.0.2.3]/12
192.0.2.3 0 100 0 ?
*> [1][100:100][192.0.2.7]/12
0.0.0.0 32768 ?
*>i [1][100:100][192.0.2.21]/12
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.15][232.0.0.1][192.0.2.1]/22
192.0.2.1 0 100 0 ?
*>i [3][100:100][192.0.2.16][224.1.1.2][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][225.1.1.1][192.0.2.21]/22
Network Next Hop Metric LocPrf Weight Path
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][226.1.1.1][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][227.1.2.3][192.0.2.21]/22
192.0.2.21 100 0 i
*>i [3][100:100][192.0.2.16][232.0.0.1][192.0.2.21]/22
192.0.2.21 100 0 i
R7#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.0.2.21, 232.21.21.5), 6d06h/00:03:15, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
GigabitEthernet1.67, Forward/Sparse, 6d05h/00:03:15
MVRF MVPN, Forward/Sparse, 6d06h/00:00:15
(192.0.2.21, 232.21.21.6), 6d05h/00:03:09, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
GigabitEthernet1.67, Forward/Sparse, 6d05h/00:03:09
MVRF MVPN, Forward/Sparse, 6d05h/00:01:17
(192.0.2.21, 232.21.21.7), 03:30:38/00:02:37, flags: sTZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
GigabitEthernet1.67, Forward/Sparse, 03:30:38/00:02:37
(192.0.2.21, 232.21.21.3), 6d12h/00:01:19, flags: sPTZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list: Null
(192.0.2.21, 232.21.21.8), 03:30:26/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 03:30:26/00:02:32
(192.0.2.21, 232.0.0.1), 6d06h/00:02:47, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
GigabitEthernet1.67, Forward/Sparse, 6d06h/00:02:47
MVRF MVPN, Forward/Sparse, 6d06h/00:02:47
(192.0.2.7, 232.0.0.1), 6d12h/00:03:22, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1.127, Forward/Sparse, 6d07h/00:03:22
GigabitEthernet1.67, Forward/Sparse, 6d07h/00:03:17
(192.0.2.3, 232.0.0.1), 6d12h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.67, RPF nbr 100.64.67.6
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d07h/00:02:52
(192.0.2.1, 232.0.0.1), 6d12h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d07h/00:02:52
(192.0.2.1, 232.1.1.0), 6d07h/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1.127, RPF nbr 100.64.127.12
Outgoing interface list:
MVRF MVPN, Forward/Sparse, 6d07h/00:00:04
We see that R7 shows a number of routes in the MRIB, most of them indicate the CE has signaled interest in joining the SSM and ASM groups.
R7#sh ip mroute vrf MVPN
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.0.2.15, 232.0.0.1), 1w0d/00:03:02, flags: sTIY
Incoming interface: Tunnel1, RPF nbr 192.0.2.1, MDT:[192.0.2.1,232.1.1.0]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 1w0d/00:03:02
(*, 226.1.1.1), 6d12h/00:02:36, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 6d07h/00:02:36
(192.0.2.16, 226.1.1.1), 6d06h/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.5]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 6d06h/00:02:36
(*, 225.1.1.1), 6d05h/00:02:44, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 6d05h/00:02:44
(192.0.2.16, 225.1.1.1), 6d05h/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.6]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 6d05h/00:02:44
(*, 227.1.2.3), 6d06h/00:02:39, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 6d06h/00:02:39
(192.0.2.16, 227.1.2.3), 03:30:42/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.8]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 03:30:42/00:02:39
RP/0/0/CPU0:XR1#sh bgp ipv4 mvpn
Tue Dec 18 01:10:32.283 UTC
BGP router identifier 192.0.2.21, local AS number 1.50693
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 34
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs
Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf CORE)
*>i[1][192.0.2.1]/40 192.0.2.1 0 100 0 ?
*>i[1][192.0.2.3]/40 192.0.2.3 0 100 0 ?
*>i[1][192.0.2.7]/40 192.0.2.7 0 100 0 ?
*> [1][192.0.2.21]/40 0.0.0.0 0 i
*>i[3][32][192.0.2.15][32][232.0.0.1][192.0.2.1]/120
192.0.2.1 0 100 0 ?
*> [3][32][192.0.2.16][32][224.1.1.2][192.0.2.21]/120
0.0.0.0 0 i
*> [3][32][192.0.2.16][32][225.1.1.1][192.0.2.21]/120
0.0.0.0 0 i
*> [3][32][192.0.2.16][32][226.1.1.1][192.0.2.21]/120
0.0.0.0 0 i
*> [3][32][192.0.2.16][32][227.1.2.3][192.0.2.21]/120
0.0.0.0 0 i
*> [3][32][192.0.2.16][32][232.0.0.1][192.0.2.21]/120
0.0.0.0 0 i
RP/0/0/CPU0:XR1#sh mrib route
Tue Dec 18 01:10:47.432 UTC
IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
LD - Local Disinterest, DI - Decapsulation Interface
EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
IRMI - IR MDT Interface
(*,224.0.0.0/4) RPF nbr: 100.64.114.4 Flags: C RPF P
Up: 1w1d
(*,224.0.0.0/24) Flags: D P
Up: 1w1d
(*,224.0.1.39) Flags: S P
Up: 1w1d
(*,224.0.1.40) Flags: S P
Up: 1w1d
Outgoing Interface List
Loopback0 Flags: II LI, Up: 1w1d
(*,232.0.0.0/8) Flags: D P
Up: 1w1d
(192.0.2.1,232.0.0.1) RPF nbr: 100.64.114.4 Flags: RPF MD MH CD
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d06h
Incoming Interface List
GigabitEthernet0/0/0/0.114 Flags: A, Up: 6d06h
Outgoing Interface List
Loopback0 Flags: F NS, Up: 6d06h
(192.0.2.3,232.0.0.1) RPF nbr: 100.64.114.4 Flags: RPF MD MH CD
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d06h
Incoming Interface List
GigabitEthernet0/0/0/0.114 Flags: A, Up: 6d06h
Outgoing Interface List
Loopback0 Flags: F NS, Up: 6d06h
(192.0.2.7,232.0.0.1) RPF nbr: 100.64.112.120 Flags: RPF MD MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d07h
Incoming Interface List
GigabitEthernet0/0/0/0.112 Flags: A, Up: 6d07h
Outgoing Interface List
Loopback0 Flags: F NS, Up: 6d06h
GigabitEthernet0/0/0/0.114 Flags: F NS, Up: 6d07h
(192.0.2.21,232.0.0.1) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 1w0d
Incoming Interface List
Loopback0 Flags: F A, Up: 1w0d
Outgoing Interface List
Loopback0 Flags: F A, Up: 1w0d
GigabitEthernet0/0/0/0.112 Flags: F NS, Up: 6d06h
GigabitEthernet0/0/0/0.114 Flags: F NS, Up: 6d06h
(192.0.2.21,232.21.21.4) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d06h
Incoming Interface List
Loopback0 Flags: F A, Up: 6d06h
Outgoing Interface List
Loopback0 Flags: F A, Up: 6d06h
GigabitEthernet0/0/0/0.114 Flags: F NS, Up: 6d06h
(192.0.2.21,232.21.21.5) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d06h
Incoming Interface List
Loopback0 Flags: F A, Up: 6d06h
Outgoing Interface List
Loopback0 Flags: F A, Up: 6d06h
GigabitEthernet0/0/0/0.112 Flags: F NS, Up: 6d06h
(192.0.2.21,232.21.21.6) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 6d05h
Incoming Interface List
Loopback0 Flags: F A, Up: 6d05h
Outgoing Interface List
Loopback0 Flags: F A, Up: 6d05h
GigabitEthernet0/0/0/0.112 Flags: F NS, Up: 6d05h
(192.0.2.21,232.21.21.7) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 03:31:28
Incoming Interface List
Loopback0 Flags: F A, Up: 03:31:28
Outgoing Interface List
Loopback0 Flags: F A, Up: 03:31:28
GigabitEthernet0/0/0/0.112 Flags: F NS, Up: 03:31:28
(192.0.2.21,232.21.21.8) RPF nbr: 192.0.2.21 Flags: RPF ME MH
MVPN TID: 0xe0000011
MVPN Remote TID: 0x0
MVPN Payload: IPv4
MDT IFH: 0x880
Up: 03:31:16
Incoming Interface List
Loopback0 Flags: F A, Up: 03:31:16
Outgoing Interface List
Loopback0 Flags: F A, Up: 03:31:16
GigabitEthernet0/0/0/0.112 Flags: F NS, Up: 03:31:16
RP/0/0/CPU0:XR1#sh mrib vrf CORE route
Tue Dec 18 01:11:21.779 UTC
IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
LD - Local Disinterest, DI - Decapsulation Interface
EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
IRMI - IR MDT Interface
(*,224.0.0.0/4) RPF nbr: 192.0.2.1 Flags: C RPF P
Up: 6d06h
(*,224.0.0.0/24) Flags: D P
Up: 1w1d
(*,224.0.1.39) Flags: S P
Up: 1w1d
(*,224.0.1.40) Flags: S P
Up: 1w1d
Outgoing Interface List
GigabitEthernet0/0/0/0.204 Flags: II LI, Up: 1w1d
(192.0.2.16,224.1.1.2) RPF nbr: 100.64.204.16 Flags: RPF
Up: 03:32:02
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 03:32:02
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 03:32:02
(192.0.2.16,225.1.1.1) RPF nbr: 100.64.204.16 Flags: RPF
Up: 6d05h
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 6d05h
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 6d05h
(192.0.2.16,226.1.1.1) RPF nbr: 100.64.204.16 Flags: RPF
Up: 6d06h
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 6d06h
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 6d06h
(192.0.2.16,227.1.2.3) RPF nbr: 100.64.204.16 Flags: RPF
Up: 03:31:50
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 03:31:50
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 03:31:50
(*,232.0.0.0/8) Flags: D P
Up: 1w1d
(192.0.2.16,232.0.0.1) RPF nbr: 100.64.204.16 Flags: RPF
Up: 6d06h
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 6d06h
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 6d06h
Now it's time to ping or send traffic from the source to the receivers.
R15#ping 227.1.2.3 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 227.1.2.3, timeout is 2 seconds:
.
Reply to request 1 from 100.64.211.17, 3 ms
Reply to request 1 from 192.0.2.18, 6 ms
Reply to request 1 from 100.64.214.18, 6 ms
Reply to request 1 from 192.0.2.17, 3 ms
R15#ping 225.1.1.1 source lo0 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.0.2.15
Reply to request 0 from 100.64.214.18, 12 ms
Reply to request 0 from 192.0.2.18, 13 ms
Reply to request 1 from 192.0.2.18, 9 ms
Reply to request 1 from 192.0.2.18, 9 ms
We ping the ASM group and the SSM group from R15.
R1#sh ip mroute vrf MVPN
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 226.1.1.1), 12:08:00/00:02:50, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 12:08:00/00:02:50
(192.0.2.16, 226.1.1.1), 11:42:27/00:00:23, flags: PT
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
(*, 225.1.1.1), 12:10:08/00:02:51, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 12:10:08/00:02:51
(192.0.2.15, 225.1.1.1), 00:02:47/00:00:12, flags: T
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 00:02:47/00:02:51
(*, 227.1.2.3), 00:21:02/00:03:13, RP 192.0.2.15, flags: S
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 00:21:02/00:03:13
(192.0.2.15, 227.1.2.3), 00:02:52/00:00:07, flags: T
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 00:02:52/00:03:13
(100.64.201.15, 227.1.2.3), 00:02:54/00:00:05, flags: JT
Incoming interface: GigabitEthernet1.201, RPF nbr 100.64.201.15
Outgoing interface list:
Tunnel0, Forward/Sparse, 00:02:54/00:03:13
(192.0.2.16, 227.1.2.3), 00:15:17/stopped, flags: PT
Incoming interface: Tunnel0, RPF nbr 192.0.2.21
Outgoing interface list: Null
R1 shows both (*, G) and (S, G) entries in the VRF aware MRIB table. R1 is the first hop router or PE that connects to the sender.
R16#ping 226.1.1.1 source lo0 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 226.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.0.2.16
Reply to request 0 from 100.64.211.17, 8 ms
Reply to request 0 from 192.0.2.17, 11 ms
Reply to request 0 from 192.0.2.17, 10 ms
Reply to request 1 from 192.0.2.17, 9 ms
Reply to request 1 from 192.0.2.17, 9 ms
R16#ping 227.1.2.3 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 227.1.2.3, timeout is 2 seconds:
Reply to request 0 from 100.64.211.17, 11 ms
Reply to request 0 from 192.0.2.17, 16 ms
Reply to request 0 from 192.0.2.18, 16 ms
Reply to request 0 from 100.64.214.18, 16 ms
Reply to request 1 from 192.0.2.18, 12 ms
Reply to request 1 from 192.0.2.17, 13 ms
R16 pings or sends traffic to the multicast groups.
RP/0/0/CPU0:XR1#sh mrib vrf CORE route
Wed Dec 19 13:12:22.679 UTC
IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
CD - Conditional Decap, MPLS - MPLS Decap, EX - Extranet
MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
LD - Local Disinterest, DI - Decapsulation Interface
EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
IRMI - IR MDT Interface
(192.0.2.16,226.1.1.1) RPF nbr: 100.64.204.16 Flags: RPF
Up: 11:44:08
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 11:44:08
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 11:44:08
(100.64.204.16,227.1.2.3) RPF nbr: 100.64.204.16 Flags: RPF
Up: 00:01:41
Incoming Interface List
mdtCORE Flags: A MI, Up: 00:01:41
(192.0.2.16,227.1.2.3) RPF nbr: 100.64.204.16 Flags: RPF
Up: 00:16:05
Incoming Interface List
GigabitEthernet0/0/0/0.204 Flags: A, Up: 00:16:05
Outgoing Interface List
mdtCORE Flags: F NS MI MA, Up: 00:16:05
XR1 is directly connected to R16 and is the first hop router.
R3#sh ip mroute vrf MVPN
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 226.1.1.1), 12:30:29/00:02:46, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 12:30:29/00:02:46
(192.0.2.16, 226.1.1.1), 12:05:48/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.0]/never
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 12:05:48/00:02:46
(*, 227.1.2.3), 00:43:31/00:03:17, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 00:43:31/00:03:17
(100.64.201.15, 227.1.2.3), 00:00:13/00:02:46, flags: T
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 00:00:13/00:03:17
(192.0.2.15, 227.1.2.3), 00:00:22/00:02:37, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.1, MDT:[192.0.2.1,232.1.1.0]/never
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 00:00:22/00:03:17
(192.0.2.16, 227.1.2.3), 00:37:46/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.2]/never
Outgoing interface list:
GigabitEthernet1.211, Forward/Sparse, 00:37:46/00:03:17
R3 is a last hop router in the PE network, connecting to R17, we see the ASM and SSM groups showing up. The (S, G) entries have an MDT mapping where the (*, G) entries do not. The reason is that the mapping is needed to point to the first hop router that connects to the source. This builds the RPF connection over the tunnel that will be used to deliver the multicast traffic over.
R7#sh ip mroute vrf MVPN
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.1.1.1), 12:35:07/stopped, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 12:35:07/00:03:16
(192.0.2.15, 225.1.1.1), 00:00:07/00:02:52, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.1, MDT:[192.0.2.1,232.1.1.1]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 00:00:07/00:03:22
(*, 227.1.2.3), 00:45:50/00:02:54, RP 192.0.2.15, flags: S
Incoming interface: Tunnel1, RPF nbr 192.0.2.1
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 00:45:50/00:02:54
(100.64.201.15, 227.1.2.3), 00:02:43/00:00:16, flags: T
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 00:02:43/00:02:54
(192.0.2.15, 227.1.2.3), 00:02:52/00:00:07, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.1, MDT:[192.0.2.1,232.1.1.2]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 00:02:52/00:02:54
(192.0.2.16, 227.1.2.3), 00:40:15/stopped, flags: TY
Incoming interface: Tunnel1, RPF nbr 192.0.2.21, MDT:[192.0.2.21,232.21.21.2]/never
Outgoing interface list:
GigabitEthernet1.214, Forward/Sparse, 00:40:15/00:03:14
R7 has the same outputs, just different SSM groups, 227.1.2.3 is the ASM group R17 and R18 are joined to.
Thanks for stopping by!
Rob Riker, CCIE #50693
No comments:
Post a Comment